但行好事
莫论前程❤

Maven插件使用—-maven-compiler-plugin

pom.xml配置

            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>2.3.2</version>
                <configuration>
                    <source>1.7</source>
                    <target>1.7</target>
                    <encoding>${sourceEncoding}</encoding>
<!-- 
                    <compilerArguments>
                        <verbose />
                        <bootclasspath>${java.home}/lib/rt.jar</bootclasspath>
                    </compilerArguments>
-->
                </configuration>
            </plugin>

​ 指定java的版本.

原因:

考虑到jdk的向下兼容问题.

编译项目时指定较低版本的jdk.可以达到jdk兼容的效果,比如编译时使用jdk1.7 则jdk1.7和1.8都可以使用

赞(0) 打赏
未经允许不得转载:刘鹏博客 » Maven插件使用—-maven-compiler-plugin
分享到: 更多 (0)

评论 抢沙发

评论前必须登录!

 

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏